window7上爬虫框架Scrapy的安装 --错误分析lxml

本文讲解的是python已经安装成功的情况下,且pip可以使用

版本:python2.7.10

#安装
pip install Scrapy

在安装Scrapy框架时总会报lxml安装不了的各种错误,如果你没有报这个错误完全可以忽视这篇文章。

#这时就必须自己手动的去安装lxml模块了,网址为https://pypi.python.org/pypi/lxml选择对应的版本,
我选择:
https://pypi.python.org/packages/2.7/l/lxml/lxml-3.5.0.win-amd64-py2.7.exe#md5=9d0c481f78928cd9d5a6b7f9fc53edef #下载完成自行安装

接下来,在重新安装就可以成功了。

重点就是对lxml版本选择,我之前用的是python3.0+的版本,一直找不到对应的lxml,最后就选择了2.7版本

原文地址:https://www.cnblogs.com/yxpblog/p/5036318.html